Lazy Load [img]

xF2 Add-on Lazy Load [img] 2.5.0

No permission to download
Compatible XF Versions
2.0, 2.1, 2.2
Visible Branding
No
Additional Requirements
php 7.0+
Require Client Browsers to be at least IE9, Firefox or Chrome.
Link XF Versions
XF2.1: https://enxf.net/resources/lazy-load-img.1285/version/5388/download
A zero query method for per user-group lazy loading of the and
  • Enable Outside threads/Conversations
    • permits the lazy loading bbcode injection to run outside of those contexts. Inside those context it will still respect permissions.
  • Force Lazy Loaded Spoiler

Unveil effects
Add styling to your theme for the classes: lazyload, lazyloading, lazyloaded.

Fade in
CSS:
/* fade image in after load */
.lazyload,
.lazyloading {
    opacity: 0;
}
.lazyloaded {
    opacity: 1;
    transition: opacity 300ms;
}
Spinner
CSS:
/* fade image in while loading and show a spinner as background image (good for progressive images) */

.lazyload {
    opacity: 0;
}

.lazyloading {
    opacity: 1;
    transition: opacity 300ms;
    background: #f7f7f7 url(loader.gif) no-repeat center;
}
Licensing:

Lazysizes is MIT Licensed, as of 2018-01-10.
Original source is https://github.com/aFarkas/lazysizes



Contributing features or bug fixes
Please create a Github Pull request via the "More Information" link.

Contributions

If you appreciate this addon, please consider a contribution via PayPal. Details will be provide via private conversation.

Please contact me if you wish for different licencing arrangements.
  • Lazy Load [img]
    options.png
    5.1 KB · Views: 548
Author
ENXF NET
Downloads
176
Views
1,785
Last update
Rating
5.00 star(s) 2 ratings

More resources from ENXF NET

Latest updates

  1. 2.5.0 - XF2.2 compatibility update

    Requires php 7.0+ Require Standard Library by Xon Rename various options to be consistantly...
  2. 2.4.1 - Bugfix update

    Fix possible race condition between lazysize library's configuration and native loading support...
  3. 2.3.0 - Maintenance update

    Require XF2.1+, drop XF2.0 support Update to lazysizes v5.2.0 from v5.1.2

Latest reviews

will test, thanks so much
thank you very much
Top