Editor box link colour issue

swift

SVIP Member
S.V.I.P Member
Registered
Joined
Apr 7, 2019
Messages
16
Time online
8h 12m
Points
3
I'm after changing link colour in editor box only for things like messages, comments when a user adds a link now in editor box it's the same colour as the text they add.

I have made a change on custom theme but that's for all links and not for editor box only, Is there any simple way to change the editor box links colours only? I am familiar with extra.css

Any help will be much appreciated.

I will provide some images to better understand.....

{F347D085-F0AD-4C49-B4C2-370BBB9C138A}.png.jpg

{294E532E-D2A7-4559-BD5D-2A577BA46876}.png.jpg

Only way to tell there is a link their is hovering over the text
 

Seang

VIP Member
V.I.P Member
Collaborate
Registered
Joined
Jan 4, 2019
Messages
15
Time online
2h 52m
Points
38
@swift I am not so sure what you are asking, but if you are asking how to change the color of links, if and any at all, so it is more visible than your grey than that, is pretty simple. Go to your style properties then go to basic color options an scroll down to till see links. By default, it is set to @xf-uix_primaryColor which I assume is your grey which is why it is appearing like that grey. You can freely change the link color here and hovered one which is usually always slightly lighter hence the light grey when hovering. Hope that answered your question.

1563752148442.png
 

swift

SVIP Member
S.V.I.P Member
Registered
Joined
Apr 7, 2019
Messages
16
Time online
8h 12m
Points
3
@swift I am not so sure what you are asking, but if you are asking how to change the color of links, if and any at all, so it is more visible than your grey than that, is pretty simple. Go to your style properties then go to basic color options an scroll down to till see links. By default, it is set to @xf-uix_primaryColor which I assume is your grey which is why it is appearing like that grey. You can freely change the link color here and hovered one which is usually always slightly lighter hence the light grey when hovering. Hope that answered your question.

View attachment 5942
Not easy to explain :D it's the links on the inside of the editor box that only you and or admins see when they edit your comment and not the out side link colour that every user sees.....

But i manged to fix it by adding
Code:
a:-webkit-any-link:read-write {
    color: #ff0018;
}
Inside of editor box is "red" (Only you & admins/mods see when editing your comment or thread & seeing links) >> Public comment links is "blue" (Outside of the comment as you or anyone is reading the comment and seeing links)
 
Last edited:
Top