If you are thinking to install a new XF site, just wait for v. 2.2.

zeus1971

Well-known member
Registered
Joined
Apr 18, 2020
Messages
144
Points
43

Reputation:

This is just my 2 cents hint for new people that would like mount or install a new XF site.
With the actual (stable) 2.1 version you would have a very good version, but probably ( quite sure..) you will need some addons.
In the new (BETA at the moment) 2.2 version, you have many features included in the standard version. No addons needed in many cases. And many 2.1 addons will not work in this new version.
So, my hint is to wait a little more if you are thinking to start with XF, and mount/install directly a new fresh 2.2 version, play and adjust it to your need. Than if you really need some addon, search for 2.2 compatible addons.

Regards.
 

Inamsay

Well-known member
Registered
Joined
Oct 1, 2019
Messages
61
Points
18

Reputation:

It will be the more complete version that does not need many addons, we have to be very careful when updating to that version. Make backup before doing anything, I also recommend doing the update in an hour that there is not much activity in the forum.
 

grindelcode

Member
Registered
Joined
Jul 24, 2020
Messages
7
Points
3

Reputation:

Any idea when the 2.2 release approximately will be?
 

zeus1971

Well-known member
Registered
Joined
Apr 18, 2020
Messages
144
Points
43

Reputation:

Mhh...reading moderators in the oficial XF forum...it seems that the next expected will be the release candidate, so my estimation viewing the devolepers speed, is end of septmber to have a stable version.
 

friend

Member
Registered
Joined
Apr 28, 2020
Messages
18
Points
13

Reputation:

Hi, I am thinking to buy XF licence, Can anyone answer my questions please.

Q: If I buy a licence now (next few days) will it cover me for XF 2.2.x when it's released and not in beta?
Q: Do I need a domain name &/or Web hosting before I buy?

And finally, With a licence do I have access to older XF versions? (like stable 2.1.10)

many thanks
 

ENXF NET

Administrator
Staff member
Administrator
Moderator
+Lifetime VIP+
S.V.I.P.S Member
V.I.P Member
Collaborate
Registered
Joined
Nov 13, 2018
Messages
7,785
Points
698

Reputation:

If you buy now, you can download the complete version xf2.1.10 patch 2 and xf2.2 beta, scheduled for late December for complete version xf2.2.
 

PeruxD

BananaForum.xyz
Registered
Joined
Nov 7, 2019
Messages
7
Points
3

Reputation:

If you need hosting, you can try two free months at sered.net with the coupon

DCSERED


Coupon apply all plans


eye is for files not nulled, as you think buying a license is acceptable
 

zeus1971

Well-known member
Registered
Joined
Apr 18, 2020
Messages
144
Points
43

Reputation:

If you set localhost as domain in XF licence, you can download it anyway, and use it in a test environment. And change it when you have a domain and host
 

friend

Member
Registered
Joined
Apr 28, 2020
Messages
18
Points
13

Reputation:

thanks all,

@ thomas Thanks for fast reply, glad to have access to 2.1.10_p2 stable version while xf2.2.x is still in beta

@zeus just what I was planning to setup for now on localhost. Nice one thanks

@enxf I was hoping to access xf2.1.10 p2 as said it's stable but hoping to get full access to xf2.2.x when out of beta testing.

Thanks
 

Replicant

SVIP Member
S.V.I.P Member
Registered
Joined
Jun 19, 2019
Messages
29
Points
23

Reputation:

Anyway it shouldn't be a titanic task to migrate 2.1 addons to be 2.2 compatible. XF is not changing drastically their development framework and the biggest changes that will come, development speaking, are related to the thread types and the editor. So the addons focused on them will be the ones more suffering with the adaption.

I advise to take a look on the addon's author, about his/her engagement, updates periodicity, activity in XF forums, etc. That could be an indicator about if he/she will migrate his/her work to be 2.2 compatible.
 

zeus1971

Well-known member
Registered
Joined
Apr 18, 2020
Messages
144
Points
43

Reputation:

Agree, but you can find that a 2.1 environment is "finally" working as expected or as you want, and after upgrading find a lot of addons (or some important for you) not working. And also spent a lot of time to setup... addons, maybe for nothing
 
View previous replies…

billybobz

Member
Registered
Joined
May 1, 2020
Messages
24
Points
13

Reputation:

@zeus1971 Oh the fallacies. ;) Regardless of any addon's significance, it still does not justify the blanket assumption made by so many. Just because a small handful do not work in XF2.2, does not justify saying all or most 2.1 addons do not work. My only point here and in the other thread is that assumptions are bad...test and verify individually. :)
fallacy.jpg
 

zeus1971

Well-known member
Registered
Joined
Apr 18, 2020
Messages
144
Points
43

Reputation:

@billybobz totally agree. But in my opinion, if you have to spent some times to config/setup your NEW site, better waiting 1 month (more or less), and not to wait for some author that have to update the addon that is not working with 2.2. And if this 2.1 addon is in production, and you have to disable it, users genarally are not "happy".
You can point that , you can wait to upgrade to 2.2 , waiting to have ALL addons working with 2.2, but 2.2 in my opinion is another world, overall if integrated with media gallery, and admins (me :D) want it NOW.
But well.., at the end, I insist, it was just an hint for new people that want to start. ;)
 

valid

SVIP Member
S.V.I.P Member
Registered
Joined
Apr 3, 2020
Messages
51
Points
18

Reputation:

I'm a licensed user of XF2.1. But I got nulled version of XF2.1 installed. I wonder what will happen if I install the official version over my current nulled version? Will anything bad happen?

And what if after my current license expired, I upgrade the licensed version with a nulled version? Will they know it?
 

zeus1971

Well-known member
Registered
Joined
Apr 18, 2020
Messages
144
Points
43

Reputation:

For what I know, no problem to be "legal" if you order later a license for a nulled XF.
Just set your site in your legal license, and upgrade it with the oficial version.
basically the problem is with BAD nulled XF, where files check is not passed when you try to upgrade.
 

th3Liam

New member
Registered
Joined
Sep 13, 2020
Messages
3
Points
3

Reputation:

How about installing XF 2.1 and upgrade to 2.2 when it comes out?
 

DareDevil

Enxf Proud Member
Staff member
Moderator
S.V.I.P Member
Collaborate
Registered
Joined
May 25, 2019
Messages
984
Points
253

Reputation:

take eveything backup before upgrading . there is no way to downgrade version .=
 

zeus1971

Well-known member
Registered
Joined
Apr 18, 2020
Messages
144
Points
43

Reputation:

As DareDevil said, do a backup before upgrade. And my point is always the same. It's not a "problem" upgrade, the point is spend time for NEW installations , to check and configure addon in a 2.1 version, that "maybe" doesn't work in 2.2. or already present with different features in standard 2.2 version.
 

Yoel Rodriguez

Well-known member
Registered
Joined
Mar 25, 2020
Messages
68
Points
18

Reputation:

A question for xenforo programmers do not think to make the complement of was in xenforo one that is for relationships that was called advance post or something like that, and that of fixing the profile message?
 
Top